Cómo configurar un Edgerouter como cliente VPN

Los clientes VPN se están volviendo muy populares en los últimos años y por una buena razón.

Protegen su privacidad y le permiten usar Internet sin restricciones (piense en ver series de Netflix que aún no están disponibles en su país).

Ahora, la desventaja de VPN es que necesitará un cliente en su dispositivo para conectarse al servidor VPN, algo que no es posible con su televisor inteligente, por ejemplo. Sin embargo, con un Edgerouter, puede configurar la VPN para toda su red.

En este artículo, explicaré cómo puede configurar EdgeRouter como un cliente VPN para los tres proveedores de VPN más grandes, NordVPN, Surfshark y ExpressVPN.

Para conectarnos al EdgeRouter por SSH usaremos Putty y subiremos los archivos de configuración al router que vamos a usar WinSCP.

Pero cualquier otro cliente SSH y FTP también servirá para este artículo.

NordVPN y Edgerouter

Entonces, primero comencemos con la configuración de NordVPN en EdgeRouter.

Necesitará sus credenciales de inicio de sesión de NordVPN, Putty para conectarse a su EdgeRouter a través de SSH y WinSCP para cargar un archivo en el enrutador.

  1. Cree un archivo en su computadora y asígnele un nombre vpnauth.txt. Abra el archivo y escriba su nombre de usuario y contraseña de NordVPN. Cada uno en su línea:nombre de usuario
    clave
  2. próximo, necesitamos descargar la configuración del servidor NordVPN. NordVPN tiene una gran herramienta para encontrar el mejor servidor cerca de su ubicación, que puede encontrar aquí: https://nordvpn.com/servers/tools/.
    En el bloque de servidor recomendado (lado izquierdo) haga clic en Mostrar todos los protocolos y descargar el Configuración UDP de OpenVPN.Enrutador de borde NordVPN

  3. Abra el archivo de configuración (haga clic con el botón derecho en él, abra con el bloc de notas), necesitamos hacer dos cambios en el archivo:- Cambio autenticación-usuario-contraseña a auth-user-pass /config/auth/vpnauth.txt
    – Agregue debajo de la línea auth-user-pass lo siguiente: ruta-nopull

    guarda el archivo

  4. Ahora necesitamos subir el archivo a nuestro enrutador. Abrir WinSCP y conéctese a su enrutador: ingrese la dirección IP del enrutador (si no conoce la dirección IP de su enrutador, puede consultar este artículo), y su nombre de usuario y contraseña:winscp-edgerouter

    Haga clic en Acceso, recibirá una advertencia de seguridad y una advertencia del propio EdgeRouter. Haga clic en Aceptar para ambas advertencias.

  5. En el lado derecho de WinSCP, verá el archivo en su EdgeRouter. Por defecto, estarás en la carpeta /inicio/ubnt. Haga clic en el icono de la carpeta raíz para navegar a la raíz del EdgeRouter. Ahora verá muchas más carpetas, incluida la configuración.winscp ir a la carpeta raíz

    Abra la carpeta de configuración y cree una nueva carpeta con el nombre auth. Establecer los permisos al 0777

    winscp crear nueva autenticación de carpeta

  6. Cargue el archivo de contraseña de nombre de usuario que creamos en el paso 1 y el archivo de configuración del paso 4 a la nueva carpeta.
  7. Abra Putty y conéctese a su EdgeRouter.Enrutador de borde de masilla SSH

    Iniciar sesión con el nombre de usuario no disponible y el clave de su EdgeRouter.

  8. Ingrese el comando a continuación:
configure #enters configuration mode on your EdgeRouter. You can close it with exit

# We uploaded the files to /config/auth. 
# REPLACE us4313.nordvpn.com.udp.ovpn with the filename that you download!
set interfaces openvpn vtun0 config-file /config/auth/us4313.nordvpn.com.udp.ovpn
set interfaces openvpn vtun0 description 'OpenVPN VPN tunnel'
commit

set service nat rule 5000 description 'OpenVPN Clients'
set service nat rule 5000 log disable
set service nat rule 5000 outbound-interface vtun0
set service nat rule 5000 source address 192.168.1.0/24
set service nat rule 5000 type masquerade
commit

set protocols static table 1 interface-route 0.0.0.0/0 next-hop-interface vtun0
set firewall modify SOURCE_ROUTE rule 10 description 'traffic from 192.168.1.0/24 to vtun0'
set firewall modify SOURCE_ROUTE rule 10 source address 192.168.1.0/24
set firewall modify SOURCE_ROUTE rule 10 modify table 1
set interfaces switch switch0 firewall in modify SOURCE_ROUTE
commit

save

La configuración se aplica después de presionar guardar. Para verificar si el Cliente VPN está funcionando en EdgeRouter, puede ingresar el siguiente comando:

run show log

Al final del archivo de registro, verá Secuencia de inicialización completada. Esto significa que su EdgeRouter está correctamente conectado a los servidores de NordVPN.

Configuración de ExpressVPN para EdgeRouter

La configuración de ExpressVPN es prácticamente la misma, solo unos pocos pasos son diferentes. Al igual que con NordVPN, necesitamos obtener un archivo de autenticación y un archivo de configuración para comenzar.

  1. Cree una cuenta en ExpressVPN.com y vaya a Mi cuenta en el menú. Haga clic en Configurar ExpressVPN y luego elige Configuración manual. Descargue el archivo de configuración (my_expressvpn_county_city_udp.ovpn)
  2. Abra el archivo de configuración con el bloc de notas. Cambia lo siguiente:- Cambio autenticación-usuario-contraseña a auth-user-pass /config/auth/vpnauth.txt
    – Agregue debajo de la línea auth-user-pass lo siguiente: ruta-nopull

    Guarda el archivo

  3. A continuación, cree un nuevo archivo en su computadora y asígnele el nombre vpnauth.txt. Abra el archivo y escriba su Nombre de usuario y contraseña de ExpressVPNencontrará estos los Mi cuenta sección donde también descargó el archivo de configuración.Asegúrese de que el nombre de usuario y la contraseña estén cada uno en su propia línea.
  4. Necesitamos cargar los archivos en EdgeRouter y conectarnos al enrutador con SSH. Siga los pasos 4 a 7 de la parte anterior de NordVPN aquí.
  5. Luego de haber subido ambos archivos a tu router podemos ingresar a la configuración:
configure #enters configuration mode on your EdgeRouter. You can close it with exit

# We uploaded the files to /config/auth. 
# REPLACE my_expressvpn_county_city_udp.ovpn with the filename that you download!
set interfaces openvpn vtun0 config-file /config/auth/my_expressvpn_county_city_udp.ovpn
set interfaces openvpn vtun0 description 'OpenVPN VPN tunnel'
commit

set service nat rule 5001 description 'OpenVPN Clients'
set service nat rule 5001 log disable
set service nat rule 5001 outbound-interface vtun0
set service nat rule 5001 source address 192.168.1.0/24
set service nat rule 5001 type masquerade
commit

set protocols static table 1 interface-route 0.0.0.0/0 next-hop-interface vtun0
set firewall modify SOURCE_ROUTE rule 10 description 'traffic from 192.168.1.0/24 to vtun0'
set firewall modify SOURCE_ROUTE rule 10 source address 192.168.1.0/24
set firewall modify SOURCE_ROUTE rule 10 modify table 1
set interfaces switch switch0 firewall in modify SOURCE_ROUTE
commit

save

Ahora debería haber conectado correctamente su EdgeRouter a ExpressVPN, lo que permite que todos los dispositivos de su red utilicen los servicios de ExpressVPN.

Configuración de Surfshark OpenVPN para EdgeRouter

También con Surfshark, podemos configurar una conexión OpenVPN desde nuestro EdgeRouter.

Surfshark es uno de los proveedores de VPN más baratos que admite dispositivos ilimitados, por lo que si aún no ha elegido una VPN, ¡asegúrese de consultar este artículo!

Al igual que los otros dos, necesitamos obtener un archivo de autenticación y un archivo de configuración para comenzar.

  1. Cree una cuenta en Surfshark.com y haga clic en Dispositivos.
  2. Desplácese hacia abajo para Avanzado y seleccione Manual. En la parte inferior de la página, encontrará sus credenciales de servicio. Necesitaremos esto más tarde.
  3. Elija una ubicación y descargue el archivo de configuración UDP
  4. Abra el archivo de configuración con el bloc de notas. Cambia lo siguiente:
    – Cambio autenticación-usuario-contraseña a auth-user-pass /config/auth/vpnauth.txt
    – Agregue debajo de la línea auth-user-pass lo siguiente: ruta-nopull
    Guarda el archivo
  5. A continuación, cree un nuevo archivo en su computadora y asígnele el nombre vpnauth.txt. Abra el archivo y escriba el nombre de usuario y contraseña de las credenciales de servicio (ver paso 2).
  6. Asegúrese de que el nombre de usuario y la contraseña estén cada uno en su propia línea.
  7. Necesitamos cargar los archivos en EdgeRouter y conectarnos al enrutador con SSH. Siga los pasos 4 a 7 de la parte anterior de NordVPN aquí.
  8. Luego de haber subido ambos archivos a tu router podemos ingresar a la configuración:
configure #enters configuration mode on your EdgeRouter. You can close it with exit

# We uploaded the files to /config/auth. 
# REPLACE us-mia.prod.surfshark.comsurfshark_openvpn_udp.ovpn with the filename that you download!

set interfaces openvpn vtun0 config-file /config/auth/us-mia.prod.surfshark.comsurfshark_openvpn_udp.ovpn
set interfaces openvpn vtun0 description 'OpenVPN VPN tunnel'
commit

set service nat rule 5001 description 'OpenVPN Clients'
set service nat rule 5001 log disable
set service nat rule 5001 outbound-interface vtun0
set service nat rule 5001 source address 192.168.1.0/24
set service nat rule 5001 type masquerade
commit

set protocols static table 1 interface-route 0.0.0.0/0 next-hop-interface vtun0
set firewall modify SOURCE_ROUTE rule 10 description 'traffic from 192.168.1.0/24 to vtun0'
set firewall modify SOURCE_ROUTE rule 10 source address 192.168.1.0/24
set firewall modify SOURCE_ROUTE rule 10 modify table 1
set interfaces switch switch0 firewall in modify SOURCE_ROUTE
commit

save

Ahora debería haber conectado correctamente su EdgeRouter a Surfshark, lo que permite que todos los dispositivos de su red utilicen los servicios de Surfshark.

Conclusión

La configuración anterior debería funcionar en principio para todos los proveedores de VPN, solo necesita un archivo de configuración de OpenVPN de su proveedor para comenzar.

Espero que este artículo le haya ayudado a configurar EdgeRouter como cliente VPN.

Las VPN son cada vez más comunes en estos días, ¿cuál es tu VPN y por qué empezaste a usarla? ¡Déjame saber abajo en los comentarios!

Otros artículos relacionados

tableta inteligente para el hogar

Cómo crear un tablero de Smart Home con una tableta

Un panel de Smart Home es una excelente manera de interactuar rápidamente con su hogar inteligente. Le permite verificar el ...
Leer Más
Power over Ethernet - ¿Qué es y cómo funciona?

Power over Ethernet – ¿Qué es y cómo funciona?

Power over Ethernet (POE), un término que se ve cada vez más en los productos de red, pero ¿qué es? ...
Leer Más
Instale el certificado Letsencrypt SSL para Unifi Controller en Raspberry Pi

Instale el certificado Letsencrypt SSL para Unifi Controller en Raspberry Pi

Una de las preguntas más frecuentes sobre el controlador Unifi es cómo deshacerse del error del certificado cuando abre el ...
Leer Más
UniFi Teleport - Cómo configurar y usar la VPN con un clic

UniFi Teleport – Cómo configurar y usar la VPN con un clic

Teleport se lanzó originalmente en 2018 para la línea de productos AmpliFi de Ubiquiti. Pero ahora también está disponible para ...
Leer Más
Cómo hacer una copia de seguridad del controlador Unifi en un almacenamiento en la nube

Cómo hacer una copia de seguridad del controlador Unifi en un almacenamiento en la nube

Hacer copias de seguridad de sus datos es importante y lo mismo ocurre con su controlador Unifi. Si una actualización ...
Leer Más
Instalación del controlador Unifi en un Synology Nas en 5 minutos — (2022)

Instalación del controlador Unifi en un Synology Nas en 5 minutos — (2022)

Si tiene equipo de red Unifi, también necesita el controlador Unifi. Y lo mejor es mantener el controlador funcionando las ...
Leer Más

Deja un comentario